Quick Links

RI Health Source Common Internet Browsers

Customers Please Note

BEFORE APPLYING ONLINE, please view the HealthSourceRI Browsers table list below for the most common internet browsers compatibility. MAKE SURE YOUR WEB BROWSER IS UP TO DATE.


The following table lists the most common internet browsers. The table lists each browser with the compatibility of TLSv1.2 for recent versions.

BROWSER TLS COMPATIBILITY NOTES
   
Microsoft Edge Compatible by default
   
Microsoft Internet Explorer (IE) Review the Internet Explorer Support for TLSv1.2 article for detailed information and instructions.
   
Desktop and mobile IE version 11 Compatible by default
   
Desktop IE versions 9 and 10 Capable when run in Windows 7 or newer, but not by default. Review the Internet Explorer Support for TLSv1.2 article to enable TLS 1.2 encryption. Windows Vista and older operating systems, such as Windows XP, are not compatible with TLS 1.2 encryption.
   
Desktop IE versions 8 and below Not compatible or stable with TLS 1.2 encryption.
 
Mozilla Firefox Compatible with the most recent, stable version, regardless of operating system
   
Firefox 27 and higher Compatible by default
   
Firefox 23 to 26 Capable, but not by default.
   
Firefox 22 and below Not compatible with TLS 1.2 or higher encryption.
   
Google Chrome Compatible with the most recent, stable version, regardless of operating system
   
Google Chrome 38 and higher Compatible by default
   
Google Chrome 22 to 37 Capable when run in Windows XP SP3, Vista, or newer (desktop), OS X 10.6 (Snow Leopard) or newer (desktop), or Android 2.3 (Gingerbread) or newer (mobile)
   
Google Chrome 21 and below Not compatible with TLS 1.2 encryption.
 
Google Android OS
   
Android 6.0 (Marshmellow) and higher Compatible by default
   
Android 5.0 (Lollipop) and higher Compatible by default
   
Android 4.4 (KitKat) to 4.4.4 Capable, but not by default.
   
Android 4.3 (Jelly Bean) and below Not compatible with TLS 1.2  encryption.
 
Apple Safari
   
Desktop Safari versions 7 and higher for OS X 10.9 (Mavericks) and higher
Compatible by default
   
Desktop Safari versions 6 and below for OS X 10.8 (Mountain Lion) and below
Not compatible with TLS 1.2 encryption.
   

Mobile Safari versions 5 and higher for iOS 5 and higher

Compatible by default
   
Mobile Safari for iOS 4 and below Not compatible with TLS 1.2 encryption.

-TO PRINT THIS DOCUMENT-